PersistentGraphicsRequestProps Interface

Wire format describing a request to produce graphics in "iMdl" format for a single element.

@see ElementGraphicsRequestProps for more details.

Extends

Properties

Name Type Description
elementId Readonly string The element whose geometry is to be used to generate the graphics.  

Inherited properties

Name Type Inherited from Description
clipToProjectExtents Readonly boolean | undefined GraphicsRequestProps If true, the element's graphics will be clipped against the iModel's project extents.
id Readonly string GraphicsRequestProps Uniquely identifies this request among all ElementGraphicsRequestProps for a given IModel.
location Readonly TransformProps | undefined GraphicsRequestProps Transform from element graphics to world coordinates.
omitEdges Readonly boolean | undefined GraphicsRequestProps If true, surface edges will be omitted from the graphics.
quantizePositions boolean | undefined GraphicsRequestProps If true, vertex positions will be quantized to QPoint3ds to conserve space; otherwise, vertex positions will use 32-bit float precision.
sectionCut Readonly string | undefined GraphicsRequestProps If defined, the compact string representation of a ClipVector to be applied to the geometry to produce section-cut
toleranceLog10 Readonly number GraphicsRequestProps Log10 of the chord tolerance with which to stroke the element's geometry.
useAbsolutePositions boolean | undefined GraphicsRequestProps Determines whether unquantized positions are specified in relative or absolute coordinates.

Defined in

Last Updated: 13 May, 2024